nodejs let notifier = require('update-notifier')({pkg}) 报错

张映 发表于 2018-07-11

分类目录: js

标签:

npm 不能用报以下错误。

/usr/local/lib/node_modules/npm/bin/npm-cli.js:79
let notifier = require('update-notifier')({pkg})
^^^

SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:374:25)
at Object.Module._extensions..js (module.js:417:10)
at Module.load (module.js:344:32)
at Function.Module._load (module.js:301:12)
at Function.Module.runMain (module.js:442:10)
at startup (node.js:136:18)
at node.js:966:3

先卸载nodejs,然后安装稳定最新版

# apt-get remove nodejs   //删除nodejs
# curl -sL https://deb.nodesource.com/setup_8.x | sudo bash - //nodejs源
# apt-get update //更新包
# apt-get install nodejs //安装nodejs
# npm install npm -g //更新npm

 



转载请注明
作者:海底苍鹰
地址:http://blog.51yip.com/jsjquery/1941.html

留下评论

留下评论
  • (必需)
  • (必需) (will not be published)
  • (必需)   6X7=?