张映 发表于 2011-01-31

分类目录: html/css

html的输入框有提示功能,你输入内容后,会记录下你在这个输入框中输入的内容,当你再输入后,就会在输入框的下面显示,以前你输入过的内容,这个设计挺好的,但是有的时候,也会带来麻烦。例如,如果我要自己来控制这个输入框的内容,像google输入框的下拉提示那样,输入框自带的提示功能就会,盖在自己设计的提示框的上面,这样就不好了。

<input  value="" title="linux  在线搜索" name="search" id="search_input" maxlength="50">

上面的这个带有自动提示功能的输入框。

<input  value="" title="linux  在线搜索" name="search" id="search_input" maxlength="50" autocomplete="off">

加上autocomplete="off"后,自动提示就没有了。

张映 发表于 2011-01-26

分类目录: js

ajax异步请求,在各种特效方面,做出了不少的贡献,有了它让用户体验更好。下面说一下曾今遇到过的一个问题,今天又遇到了,又花了我一点时间,小问题,但是特别容易忽视,并且不容易想到是什么原因产生的。废话不多说,举个例子大家就明白了。

阅读全文>>

张映 发表于 2011-01-24

分类目录: js

在做web前端的时候,我们经常会做一个特效,这个时候用到ajax来进行无刷新页面,来改变页面的内容,这个时候,我们就会对页面中的html进行添加,替换等,在接触jquery的这些html操作函数之前,我一般都是用js来完成的。个人觉得最快最方便的做法就是document.getElementById,document.getElementsByName这些方法,例如document.getElementById("id").html="<strong>aaa</strong>";这种方法有一点不好,就是你必须知道,有一个id或者是name,并且写法也比较长。反正看个人喜好吧。

一,测试文件test.html

阅读全文>>

张映 发表于 2011-01-19

分类目录: js

好长时间没有用jquery.validate.js这个插件了,忘得差不多了。唉,好东西还是要经常拿出来看看的,今天用jquery.validate来做一个小东西,遇到一个问题,就是错误提示信息的位置问题,如果知道的话,很简单。以前遇到过,可是忘了,现在标记一下,将来在忘了,在回过头看看。俗话说的好,好记性不如烂笔头。

阅读全文>>

张映 发表于 2011-01-16

分类目录: 双眼看社会

最近比较忙,忙的我不知道离过年还有十几天了,一年一年过的好快。今天出去路过一个火车票售票点,几百人的队伍真是壮观啊。至少也有一百米吧,排成二队。在外面的人不容易啊,回家难,回来也难,一票难求啊。这让我想起了07的时候,一个痛苦的买票经历。

阅读全文>>

张映 发表于 2011-01-08

分类目录: mysql

drupal7正式发布了,下载了一下,安装时候提示我错误,安装不了

Syntax error or access violation: 1286 Unknown table engine 'InnoDB'

原来是我的mysql里面,根本没有innodb存储引擎。进去后我们可以用 show engines;或者show plugins;来查看

阅读全文>>

张映 发表于 2011-01-06

分类目录: drupal

ckeditor在fkceditor基础上又一个不错的html编辑器,在新建node的时候,在用户评论的时候,有这样的编辑器,用户体验是非常的不错的

阅读全文>>

张映 发表于 2011-01-04

分类目录: drupal

一,什么是google cse

google cse是Google Custom Search Engine(google自定义搜索),我们可以通过这个搜索来搜索网络上的资源

二,drupal模块google cse安装

1,下载地址:http://drupal.org/project/google_cse

阅读全文>>

张映 发表于 2011-01-03

分类目录: 服务器相关

一,安装apache,php,phpmyadmin,mysql

apt-get install apache2 libapache2-mod-php5 php5 php5-gd  php5-mysql phpmyadmin

安装phpmyadmin的时候,会弹出个对话框,让你选择apache的类型,这里装的是apache2选择apache2就行了。在这里我为什么没有用apt-get来安装mysql呢,因为报错,如下

下列的软件包有不能满足的依赖关系:
mysql-server-5.0: 依赖: libdbi-perl 但是它将不会被安装
依赖: mysql-client-5.0 (>= 5.0.51a-3ubuntu5.8) 但是它将不会被安装
E: 无法安装的软件包

阅读全文>>

张映 发表于 2011-01-02

分类目录: drupal

drupal的url重写,后台有地方进行控制的,administer=>Site configuration=>Clean urls在这里我们可以选择,开启url重写,或者是不开启,里面有一个单选框,如果是不可选的,说明你服务器中的url重写并没有配置好,会提示以下错误

Your system configuration does not currently support this feature. The handbook page on Clean URLs has additional troubleshooting information.

要想使用http://localhost/drupal/?q=admin/settings/clean-urls这里面的单选可以点,要做到一下三步

阅读全文>>